web.config error in cassini 2.0


Y

yancheng.cheok

Hello all,

I have a web application, which I had developed few years ago with
ASP .NET 1.1

Today, I would like to deploy the web application to client, using
ASP .NET 2.0 + UltiDev Cassini 2.0

I locate my whole project in a folder named C:\website\GOWatch

My setting in UltiDev Cassini 2.0 is as follow :

Application = GoWatch
Port Number = 2040
Physical Path = C:\website\GOWatch

When I try to access an URL http://localhost:2040/DesktopPC/login/Login.aspx
(The login.aspx is located physically at C:\website\GOWatch\DesktopPC
\login\Login.aspx), I get the following error :




Configuration Error
Description: An error occurred during the processing of a
configuration file required to service this request. Please review the
specific error details below and modify your configuration file
appropriately.

Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This
error can be caused by a virtual directory not being configured as an
application in IIS.

Source Error:
Line 7:
Line 8: <system.web>
Line 9: <authentication mode="Forms">
Line 10: <forms name=".ASPXUSERDEMO" loginUrl="http://
10.0.38.4/GoWatch/DesktopPC/login/login.aspx" protection="All"
timeout="5" />
Line 11: </authentication>

Source File: C:\website\GOWatch\desktoppc\login\web.config Line:
9





In my entire application, any sub folder with web.config will have the
similar error.

Please take note that, there are NO web.config in C:\website\GOWatch,
is this the root cause of the error?

Here is the content of my web.config in C:\website\GOWatch\desktoppc
\login\web.config


<configuration>
<appSettings>
<add key="ConnectionString" value="server=GOWATCHSERVER
\NetSDK; trusted_connection=true; Database=Gowatch" />
<add key="mailserver" value="GowatchServer" />
</appSettings>

<system.web>
<authentication mode="Forms">
<forms name=".ASPXUSERDEMO" loginUrl="http://10.0.38.4/GoWatch/
PocketPC/login/login.aspx" protection="All" timeout="5" />
<deviceFilters>
<filter name="supportsJavaScript" compare="Javascript"
argument="true"/>
</deviceFilters>

</system.web>

<location path="protected">
<system.web>
<authorization>
<deny users="?" />
</authorization>
</system.web>
</location>
</configuration>

Help are very much appreciated! Thank you.

cheok
 
Ad

Advertisements

J

Juan T. Llibre

That said, the problem seems to be that the GOWatch directory is not marked as an application.

UltiDev Cassini is *not* Cassini, btw.
It's a propietary server version based on the Cassini source and owned by UltiDev LLC.

Are you using UltiDev Cassini 1.1 or UltiDev Cassini 2.0 ?
 
J

Juan T. Llibre

Here's the reply from the UltiDev Forums :

---000---
If your application is located entirely in the "DesktopPC" sub-folder, you need to register
the application with the physical location of "C:\website\GOWatch\DesktopPC".

If not, please be sure that your application root folder "C:\website\GOWatch"
contains a web.config if you want to specify root-level settings, like Authentication type.

In general, application root folder does not necessarily need to contain a web.config,
but some web.config settings seem be required to be in the root-level web.config.
---000---

Good luck...
 
Ad

Advertisements

Y

yancheng.cheok

Thanks! I just do a quick hacking by removing all the web.config and
move them to the root folder. Anyway, this just suit to my
requirement :)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top