Web Service Deployment Issues

Discussion in 'ASP .Net Web Services' started by Sathyaish, Feb 2, 2006.

  1. Sathyaish

    Sathyaish Guest

    I have a Web Service developed using C# and the .NET framework v1.1.

    When I access the DLL on the localhost, using the URL

    http://localhost/Folder/bin/MyService.dll

    it works fine. However, when I x-copy deploy the DLL and its web.config
    (authorization allow *) to a remote server and set all permissions for
    the account ASPNET (the local ASPNET account), I have problems
    accessing the same url remotely like:

    http://remoteserver/Folder/bin/MyService.dll

    Any pointers?
    Sathyaish, Feb 2, 2006
    #1
    1. Advertising

  2. Sathyaish

    Dale Guest

    Shouldn't you be using http://remoteserver/folder/myservice.asmx to access
    your webservice?
    --
    Dale Preston
    MCAD C#
    MCSE, MCDBA


    "Sathyaish" wrote:

    > I have a Web Service developed using C# and the .NET framework v1.1.
    >
    > When I access the DLL on the localhost, using the URL
    >
    > http://localhost/Folder/bin/MyService.dll
    >
    > it works fine. However, when I x-copy deploy the DLL and its web.config
    > (authorization allow *) to a remote server and set all permissions for
    > the account ASPNET (the local ASPNET account), I have problems
    > accessing the same url remotely like:
    >
    > http://remoteserver/Folder/bin/MyService.dll
    >
    > Any pointers?
    >
    >
    Dale, Feb 2, 2006
    #2
    1. Advertising

  3. Sathyaish

    Sathyaish Guest

    Thanks. That was an obvious bit I forgot. I am sure I knew that
    somewhere in my brain but just totally brain farted on it.

    Now, what are the other files that one deploys when deploying a web
    service? The asmx, the dll and what? I am sure you don't deploy the .cs
    file?
    Sathyaish, Feb 2, 2006
    #3
  4. Sathyaish,
    Normaill you would deploy the built assembly (dll) into the /bin folder,
    the .asmx file, and the web.config and global.asax files.

    Ensure that the debug setting in web.config is set to "false" and that you
    have built the service in Release mode build configuration.
    It also needs to be an IIS Application.

    Peter

    --
    Co-founder, Eggheadcafe.com developer portal:
    http://www.eggheadcafe.com
    UnBlog:
    http://petesbloggerama.blogspot.com




    "Sathyaish" wrote:

    > Thanks. That was an obvious bit I forgot. I am sure I knew that
    > somewhere in my brain but just totally brain farted on it.
    >
    > Now, what are the other files that one deploys when deploying a web
    > service? The asmx, the dll and what? I am sure you don't deploy the .cs
    > file?
    >
    >
    Peter Bromberg [C# MVP], Feb 2, 2006
    #4
  5. Sathyaish

    Sathyaish Guest

    Thanks, Peter. It seems I'd just not cared to copy the asmx probably
    because I didn't know or probably knew but had forgotten. I'd copied
    the web.config though and set the correct authorization, customErrors
    (@mode=RemoteOnly, which is also the default) etc.

    Good thing you reminded me about the debug switch. I know that also but
    I have forgotten the syntax for that. It was something like:

    <somethng here debug="false" />

    that helped not to pop up the "dude! wanna debug? What're you gonna
    use?". What was the syntax, please?
    Sathyaish, Feb 2, 2006
    #5
  6. You have to deploy:

    1. DLL (/bin)
    2. ASMX

    No code files.

    NOTE that this can technically just be the DLL in 2.0, if you compile using
    the command line tools (prep for no file deploy, or whatever it is called).

    --
    Gregory A. Beamer
    MVP; MCP: +I, SE, SD, DBA

    ***************************
    Think Outside the Box!
    ***************************


    "Sathyaish" wrote:

    > Thanks. That was an obvious bit I forgot. I am sure I knew that
    > somewhere in my brain but just totally brain farted on it.
    >
    > Now, what are the other files that one deploys when deploying a web
    > service? The asmx, the dll and what? I am sure you don't deploy the .cs
    > file?
    >
    >
    Cowboy (Gregory A. Beamer) - MVP, Feb 3, 2006
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jim
    Replies:
    3
    Views:
    337
    John Saunders
    Nov 8, 2003
  2. Gene Papa
    Replies:
    0
    Views:
    314
    Gene Papa
    Nov 20, 2003
  3. Pavan Apuroop
    Replies:
    3
    Views:
    2,285
    =?Utf-8?B?c3Jpbmk=?=
    Jun 21, 2005
  4. Benny Ng
    Replies:
    0
    Views:
    4,391
    Benny Ng
    Oct 3, 2005
  5. Leo Violette
    Replies:
    0
    Views:
    1,000
    Leo Violette
    Apr 17, 2009
Loading...

Share This Page