WebService and Oracle very slow

Discussion in 'ASP .Net Web Services' started by Jonathan Gobeil, Aug 31, 2005.

  1. I'm doing a big project where an application in Vb.Net call some WebService
    on a asp server who connect to oracle.

    On my dev server, when the webservice connect to oracle there is no problem
    and it's very fast but on my production server, it very slow, very very very
    slow or do some time out.

    All component (oracle, MDAC) are up to date, and it's not a netowrk problem
    because when a try to speak to oracle on the server with another product,
    it's very fast. It's also slow when I call the webservice from IE on the
    same server where the webservice are.

    IIS Dev Server: Intel Xeon 2.8gig 2 cpu, 1 gigs memory
    windows 2000 server, sp4

    IIS Prod Server : 2 servers in network load balancing
    Intel Xeon 3.6gig 4 cpu, 4 gigs memory
    Windows Advanced Server 2000, sp4

    On the three server
    Oracle 9i: 9.2.0.6
    MDAC: 2.8 sp1
    IIS: 5.0
    Framework: 1.1

    Can someone help me?
    Thanks

    Jonathan
     
    Jonathan Gobeil, Aug 31, 2005
    #1
    1. Advertising

  2. Jonathan Gobeil

    Ziga Jakhel Guest

    Hmm... we have a similar problem, just with weaker servers. It turns out
    that the problem with our setup is simply the load the production server is
    under normally.

    Any idea what the "regular" workload - beside your application/webservice -
    on your production server is?

    Regards,

    Ziga

    "Jonathan Gobeil" <> wrote in message
    news:%...
    > I'm doing a big project where an application in Vb.Net call some
    > WebService
    > on a asp server who connect to oracle.
    >
    > On my dev server, when the webservice connect to oracle there is no
    > problem
    > and it's very fast but on my production server, it very slow, very very
    > very
    > slow or do some time out.
    >
    > All component (oracle, MDAC) are up to date, and it's not a netowrk
    > problem
    > because when a try to speak to oracle on the server with another product,
    > it's very fast. It's also slow when I call the webservice from IE on the
    > same server where the webservice are.
    >
    > IIS Dev Server: Intel Xeon 2.8gig 2 cpu, 1 gigs memory
    > windows 2000 server, sp4
    >
    > IIS Prod Server : 2 servers in network load balancing
    > Intel Xeon 3.6gig 4 cpu, 4 gigs memory
    > Windows Advanced Server 2000, sp4
    >
    > On the three server
    > Oracle 9i: 9.2.0.6
    > MDAC: 2.8 sp1
    > IIS: 5.0
    > Framework: 1.1
    >
    > Can someone help me?
    > Thanks
    >
    > Jonathan
    >
    >
     
    Ziga Jakhel, Sep 13, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Earl Teigrob
    Replies:
    7
    Views:
    428
    Scott M.
    Feb 16, 2004
  2. Alf P. Steinbach /Usenet

    Slow -- VERY slow brain

    Alf P. Steinbach /Usenet, Jun 16, 2011, in forum: C++
    Replies:
    17
    Views:
    520
    Noah Roberts
    Jun 29, 2011
  3. Nick Green
    Replies:
    4
    Views:
    193
    Nick Green
    Nov 18, 2009
  4. Sara
    Replies:
    0
    Views:
    99
  5. Feyruz
    Replies:
    4
    Views:
    2,182
    Sherm Pendley
    Oct 14, 2005
Loading...

Share This Page