Authentication/Configuration/Web.Config Error?

Discussion in 'ASP .Net' started by Matt, Apr 6, 2006.

  1. Matt

    Matt Guest

    I am getting the following Error.

    Configuration Error
    Description: An error occurred during the processing of a configuration
    file required to service this request. Please review the specific error
    details below and modify your configuration file appropriately.

    Parser Error Message: It is an error to use a section registered as
    allowDefinition='MachineToApplication' beyond application level. This
    error can be caused by a virtual directory not being configured as an
    application in IIS.

    Source Error:

    Line 15: </compilation>
    Line 16: <customErrors mode="Off" />
    Line 17: <authentication mode="Forms">
    Line 18: <forms name="greensboro" path="/"
    loginUrl="/greensboro/Tools/ManualLogin.aspx" protection="All"
    timeout="90" >
    Line 19: </forms>

    Source File: C:\Inetpub\wwwroot\Greensboro\web.config Line: 17


    --------------------------------------------------------------------------------
    Version Information: Microsoft .NET Framework Version:1.1.4322.2300;
    ASP.NET Version:1.1.4322.2300


    I am using MCMS, but from all my research I have found that this may be
    a .NET configuration issue and not an MCMS issue.

    I am getting this issue on SOME pages, but not ALL from within my site.
    I have looked through the code but have not spotted any differences
    from one page to the next, so I am not exactly sure what might be
    causing the error.

    If i change the authentication type or I remove the authentication
    block in the Web.Config I still get the same issue.

    Any help appreciated...

    Thanks
    Matt
     
    Matt, Apr 6, 2006
    #1
    1. Advertisements

  2. Hi Matt,

    This is usually caused by one of two things:

    1) A virtual directory is not configured as an application when it
    should be, as the errors says. To fix this, open IIS, righ-click the
    offending folder and select Properties. Select the Directory tab then
    click the Create button under Application Settings.

    2) One of your sub folders contains a web.config file that shouldn't be
    there. .NET will think the folder should be an application, so it
    complains. Simply move or delete the web.config file.

    Hope that helps,

    Chris
     
    Chris Fulstow, Apr 6, 2006
    #2
    1. Advertisements

  3. Matt

    Matt Guest

    I have done this before, but for the sake of this argument I removed
    the Application and re-created it.
    I have done a search on all subfolders an none of them contain a
    web.config file. However I did find a web.config file under a
    sub-virtual (non-application) that when removed fixed the problem

    Thanks
    Matt
     
    Matt, Apr 6, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.