Couple of soap errors when trying to invoke a method on the web service

Discussion in 'ASP .Net Web Services' started by sadhvi, Jun 6, 2005.

  1. sadhvi

    sadhvi Guest

    Hi there!!

    I am consuming an ASP.Net webservice from a simple .Net application by
    adding a web reference. However when I invoke the web method, we see a
    couple of soap error entries in the application event log with the
    result that the http request is not successfully completed.

    We even tried to invoke the web method directly from the asmx page in
    IE providing in the required parameters. We still get the same errors.

    Please note this problem is intermittent and does not happend
    everytime.

    The following are the event log entries:

    Soap error: XML Parser failed at linenumber 0, lineposition 0, reason
    is: The download of the specified resource has failed.
    Soap error: Soap client is not initialized.
    Soap error: One of the parameters supplied is invalid..
    Soap error: Loading of the WSDL file failed.

    Sometimes we get a little different kind of event log entries as given
    below:

    aspnet_wp.exe (PID: 2228) stopped unexpectedly.
    Soap error: One of the parameters supplied is invalid..

    Soap error: Loading of the WSDL file failed.

    Soap error: XML Parser failed at linenumber 0, lineposition 0, reason
    is:
    The system cannot locate the object specified.

    We fail to understand as to where is the problem. We can easily browse
    to the wsdl file successfully.
    We are not invoking any SoapToolkit 3.0.

    Any help will be greatly appreciated.

    Thanks,
    Sadhvi
     
    sadhvi, Jun 6, 2005
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.