fixrbconfig on Mac OS X Tiger

Discussion in 'Ruby' started by Bill Whitacre, Sep 24, 2006.

  1. I'm trying to get the Mac OS X Ruby fix to run -- from p.24 of "Agile
    Web Development with Rails"

    I can d/l it ok with

    sudo gem install fixrbconfig

    but then when I run sudo fixrbconfig I get:
    I tried the 'fix' for this listed here:

    <http://www.smallroomsoftware.com/articles/2006/02/26/setting-up-ruby-
    on-rails-and-fastcgi-on-mac-os-x-server>

    but when I do that I get:

    pb17-upstairs:/usr/lib/ruby/1.8 bw$ ln -s universal-darwin8.0/*
    powerpc-darwin8.0
    ln: powerpc-darwin8.0: No such file or directory

    When I try it with sudo, I get the same thing:

    pb17-upstairs:/usr/lib/ruby/1.8 bw$ sudo ln -s universal-darwin8.0/*
    powerpc-darwin8.0
    ln: powerpc-darwin8.0: No such file or directory

    That's as far as Googling got me. Is there another source I'm
    overlooking?

    Thanks.

    bw
     
    Bill Whitacre, Sep 24, 2006
    #1
    1. Advertisements

  2. Bill Whitacre

    ryan.raaum Guest

    If you're willing to drop the ill-advised "fixing" of Apple's ruby
    installation, I would suggest either:

    1. For building from scratch:
    http://hivelogic.com/articles/2005/12/01/ruby_rails_lighttpd_mysql_tiger

    2. For a quick start:
    http://locomotive.raaum.org

    -r
     
    ryan.raaum, Sep 24, 2006
    #2
    1. Advertisements

  3. Bill Whitacre

    Hans Fugal Guest

    Did you install XCode? Maybe you have an intel mac, not a powerpc mac? I
    don't know if the script does or doesn't work with intel macs, but it
    worked for my powerpc iBook G4. I'm getting a MacBook soon, so I'll be
    watching the thread with interest. I'm probably going to just compile my
    own ruby though. It's too late for me on the iBook to go that route, but
    I think it's a bit cleaner.
     
    Hans Fugal, Sep 26, 2006
    #3
  4. Bill Whitacre

    Reprisal Guest

    Ruby is also available via DarwinPorts which is pretty nice. I'd
    recommend doing a clean install either via port or manually compiling
    it. It will take more CPU time but probably less of your own time
    and provide a cleaner result in the end. With out the developer
    tools you wont be able to do anything, because you wont have gcc.
    Grab the tools from your install disk or http://developer.apple.com/
    tools/ .
     
    Reprisal, Sep 26, 2006
    #4
  5. Bill Whitacre

    Hans Fugal Guest


    I actually did use the ports version for awhile at the beginning and it
    only confused things. It will take less me-time to install, yes, but it
    will not (IMHO) be a cleaner result.
     
    Hans Fugal, Sep 27, 2006
    #5
  6. Bill Whitacre

    gwtmp01 Guest

    I just went the other way, moving from compiling on my own to using
    darwin ports. I did have to install the newest version of Xcode but
    after that everything just worked on both an Intel MacBook and an
    older PowerPC Imac.


    Gary Wright
     
    gwtmp01, Sep 27, 2006
    #6
  7. Bill Whitacre

    Amos King Guest

    Why not just grab locomotive. It is nice, easy, and seperates your
    development enviroment from the rest of the mac. And if you don't
    like something you can just drag the folder to the trash and start
    over.
     
    Amos King, Sep 27, 2006
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.