[help] Ruby execution on XP machine: Access is denied

Discussion in 'Ruby' started by Maurizio Pedriale, Feb 6, 2009.

  1. Hello everybody,
    I need some help on a strange error I'm getting when I try to execute
    ruby from command line.
    I recently reinstalled everything on my HP laptop (XP sp3), and I've
    also reinstalled ruby (1.8.6 with one-click installer). Since then I'm
    unable to launch ruby from the command line, the message I get is
    always: "Access is denied".
    I tried to check and change security permissions on ruby installation
    folder but nothing changed. The strange thing is that with NetBeans
    (which is set to use the same ruby interpreter) the execution is fine.

    Can anyone help me, please?
     
    Maurizio Pedriale, Feb 6, 2009
    #1
    1. Advertisements

  2. Maurizio Pedriale

    Roger Pack Guest

    It does sound like a permissions setting, or it sometimes happens when
    it tries to delete a file that's in use.
    Try copying the ruby folder around, running it.
     
    Roger Pack, Feb 7, 2009
    #2
    1. Advertisements

  3. Thank you Roger, I checked my firewall software (Comodo) event log and I
    found that the executions were always blocked due to security policies.
    Everything is fine now.

    m.
     
    Maurizio Pedriale, Feb 7, 2009
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.