I need some help on a format issue that should be simple for someone here (but not me!)

Joined
Jun 23, 2023
Messages
3
Reaction score
0
So here is the background. I have an F150 with sync media center that uses QNX as its programming. I modified it and there are numerous programs that allow you to put customization into it. I’m having a lot of trouble with the syntax of this one.

The one I am trying to install eliminates an error message that every time I plug in my AirPods to charge, it has a pop-up saying, “unsupported USB device”. This occurs every few minutes across the screen, and has to be cleared out to see past it, which gets very irritating throughout a drive.

In this program, it says I must install my HID/PID (which I found) in the two separate files. I’ve tried multiple combinations and have had no success. I believe I am just putting it in the wrong order or missing something simple. Please see the coding below and offer any help if you are familiar with it.

My HID/PID info from the AirPods case (hardware ID's):
HID/VID_05AC&PID_1393&REV_0139
HID/VID_05AC&PID_1393
HID/VID_03AC&UP:FF00_U:0001
HID_DEVICE_UP:FF00_U:0001
HID_DEVICE_UPR:FF00-FFFF
HID_DEVICE


Here was my two original codes from the mod file:

Allowed Hubs:
<?xml version="1.0" encoding="utf-8"?>
<SYNC3>
<allowed_hubs>
<hub vid="0x2996" pid="0x0118" dio_port="2" upstreamport1="2" upstreamport2="3" description="MY17MCM" />
<hub vid="0x2996" pid="0x0119" dio_port="2" upstreamport1="2" upstreamport2="3" description="MY17MCM (1+1)" />
<hub vid="0x2996" pid="0x011A" dio_port="2" upstreamport1="2" upstreamport2="3" description="MY17MCM (1+SD)" />
<hub vid="0x2996" pid="0x0146" dio_port="2" upstreamport1="2" upstreamport2="3" description="MY21MCM (1+1)" />
<hub vid="0x042f" pid="0x0501" dio_port="2" upstreamport1="2" upstreamport2="3" description="Molex 2USB Hub" />
<hub vid="0x042f" pid="0x0502" dio_port="2" upstreamport1="2" upstreamport2="3" description="Molex Embedded Hub" />
<hub vid="0x042f" pid="0x0503" dio_port="2" upstreamport1="2" upstreamport2="3" description="Molex 1+1 Hub" />
<hub vid="0x042f" pid="0x0600" dio_port="2" upstreamport1="2" upstreamport2="3" description="Carplay port" />
</allowed_hubs>
</SYNC3>

Carplay_allowed_hubs:
<?xml version="1.0" encoding="utf-8"?>
<SYNC3>
<allowed_hubs num="7">
<hub1 vid="0x2996" pid="0x0118" dio_port="2" description="MY17MCM Aptiv" />
<hub2 vid="0x2996" pid="0x0119" dio_port="2" description="MY17MCM Aptiv (1+1)" />
<hub3 vid="0x2996" pid="0x0146" dio_port="2" description="MY21MCM Aptiv (1+1)" />
<hub4 vid="0x0559" pid="0x6560" dio_port="2" description="MY18.5 Molex FPGA HUB" />
<hub5 vid="0x042f" pid="0x0501" dio_port="2" description="MY18.5 Molex 2USB HUB" />
<hub6 vid="0x042f" pid="0x0502" dio_port="2" description="MY19 Molex Embedded HUB" />
<hub7 vid="0x042f" pid="0x0503" dio_port="2" description="MY19 Molex 1+1 HUB" />
</allowed_hubs>
</SYNC3>

I added this right above the "<allowed_hubs>" on allowed_hubs:
<hub vid="0x05AC" pid="0x1393" dio_port"2" upstreamport1="2" upstreamport2="3" description="Airpod Case" />

I did this same process to the carplay_allowed_hubs but with these changes:
Added: <hub8 vid="0x05AC" pid="0x1393" dio_port"2" description="Airpod Case" />
<allowed_hubs num="7"> went to <allowed_hubs num="8">

This still did not work. Am I to copy the allowed hubs format to the other file or what gives? I know there are two ports above each other but I don't believe the location has anything to do with it. Someone has to be able to help me please.

I also tried adding two lines of code with the different PID's of 1393 and 0139 since the one gave two values with the "&" in between. Changed allowed number to 9. No luck there either.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Forum statistics

Threads
473,790
Messages
2,569,637
Members
45,346
Latest member
EstebanCoa

Latest Threads

Top