ruby-opengl on a g4 mac 10.4


3

360percent

irb(main):001:0> require 'rubygems'
=> true
irb(main):002:0> gem 'ruby-opengl'
=> true
irb(main):003:0> require 'gl'
LoadError: Failed to lookup Init function /usr/local/lib/ruby/gems/1.8/
gems/ruby-opengl-0.40.1/lib/gl.bundle
from /usr/local/lib/ruby/gems/1.8/gems/ruby-opengl-0.40.1/lib/
gl.bundle
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:32:in `require'
from (irb):3
irb(main):004:0> require 'glut'
LoadError: Failed to lookup Init function /usr/local/lib/ruby/gems/1.8/
gems/ruby-opengl-0.40.1/lib/glut.bundle
from /usr/local/lib/ruby/gems/1.8/gems/ruby-opengl-0.40.1/lib/
glut.bundle
from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:32:in `require'
from (irb):4
irb(main):005:0>

What dependencies should I look at in order to correct this problem?

I have the apple dev tools, x11, etc...

Thanks!
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top