ruby + Qt + Windows + 64 bit

D

Donn M

To me, the ideal programming environment is ruby + Qt. On Windows, the qt-bindings gem only works with the 32 bit version of ruby, and I really need a 64 bit version (to talk to a 64 bit device driver).

The qt-bindings folks don't seem to be putting much effort into this, so I thought I'd try it myself. I tried using mingw-64 to compile everything, but I couldn't get that to work at all - so I tried using Visual C++ 2012. Here's what I did:

1. compiled ruby with VC 2012. This went smoothly.

2. compiling Qt is a headache, so I downloaded a binary version also compiled with VC 2012.

3. compiled qt-bindings. This required a lot of hacking both to the sourcecode and the cmake files, but I was actually able to get it to compile andinstall in my ruby directory.

Now the problem - I can't load Qt. If I say "require 'Qt'", I get "can't load such file -- Qt." Now Qt.rb only loads Qt4.rb, so if I try to "require'Qt4', I get "can't load such file -- 2.0/qtruby4." So I tried "require 'qtruby4'" and I get "can't load such file -- Qt/qtruby4.rb." It's never ending.

Well it looks like a path problem, but if I print the PATH, it looks like all the directories containing these files are included.

Anyone have any ideas? I'm so close.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
473,703
Messages
2,569,328
Members
44,612
Latest member
Billysak

Latest Threads

Top