The file '/AHSD/MainMenu.aspx' has not been pre-compiled, and cannot be requested.

Discussion in 'ASP .Net' started by lds, Oct 3, 2007.

  1. lds

    lds Guest

    I am getting the error "The file '/AHSD/MainMenu.aspx' has not been
    pre-compiled, and cannot be requested." when I try to deploy one of my
    applications that I am just migrating to VS 2005. I have searched on
    the web for a solution, but none of the suggestions so far have
    worked. Here is my scenario:

    I am using Visual Studio 2005 with SP1 installed and I have created a
    Web Deployment Project with the following items selected in the
    Property Pages:

    compliation tab: just defaults, nothing special selected. Output
    folder .\Release\
    output assemblies tab: Merge all pages and control outputs to a
    single assembly (AssemblyName: AHSD.CompiledApplication)
    sigining tab: just defaults
    deployment tab: just defaults

    I created a virutal directory pointing to the Release folder so that I
    could see if it worked and it seems to work perfectly. On our server
    there was an existing folder called AHSD that used to contain the
    files for the application before it was migrated. I deleted all of
    the files and copied the new ones. This is when I get the error.

    I have made sure that our Network technician has changed the virtual
    directory tab to use Framework 2.0, I asked him to restart IIS
    and I have ensured that the additional assemblies that we reference
    within the application have been registered in the GAC.

    Any other suggestions?
    lds, Oct 3, 2007
    1. Advertisements

  2. lds

    lds Guest

    This afternoon, mysteriously this application started working on our
    server. Now for some reason the other apps that are still using the
    1.1 version of the framework have stopped working. Any ideas why?
    lds, Oct 3, 2007
    1. Advertisements

  3. lds

    lds Guest

    Just incase anyone is wondering...we got this app working. It turned
    out that this app was using the same application pool as the 1.1
    apps. Once we put it in its own applicaiton pool for 2.0 apps it
    worked fine.
    lds, Oct 4, 2007
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.