Unable to register com component built with python2.7

Discussion in 'Python' started by sniffer, Feb 5, 2011.

  1. sniffer

    sniffer Guest

    Hi all,
    I have built a com component using python2.7 on win 7 but the
    component refuses to register ,every time i try to register it says
    the specified module could not be found unable to load python.dll ,i
    also tried building the same com server with python2.7 again on a win-
    xp system but to no avail ,i even tried building and registring the
    com server after removing all imports and just leaving 1 function
    which returns nothing but the string "hello world" any pointers would
    be great


    thanks
     
    sniffer, Feb 5, 2011
    #1
    1. Advertisements

  2. It sounds like your Python install directory (C:\Python27 probably) is
    not on your PATH. Which is the default. There's much debate about that
    on and off, but in short-- if you go add it to your environment
    variables things will probably work.

    --

    Stephen Hansen
    ... Also: Ixokai
    ... Mail: me+list/python (AT) ixokai (DOT) io
    ... Blog: http://meh.ixokai.io/


    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.10 (Darwin)

    iQEcBAEBAgAGBQJNTZRaAAoJEKcbwptVWx/lxjgIAIvhApx121CZ1i1zrrjeRJSi
    PntDN1zXaILuLwOSbAj7IyHhZZFNdEmqaHaBQIseEek5LTu7auX+Nlu79UrJ/NIg
    2hm97NKxxqbZlsspT3SI7vZkTtna5VAUnYpg+KdSiZB/3yLnXklZmTOsXGxSbxve
    RJDJkuy07xWwNIWWkOHE1x7NsDbLkBoBAXwkVixvolwnlKGfuYNTIoyH0cQLnZZT
    /Px6dzdXOnfaJOIumwBB2PxXhCwKN/Ic3Kl9RL1eIv1LuFN2E0TyEgdNI4gpUn+g
    0of+csqj5ACl9EM/0vovybO5UcLK3iEoLKBdkK1/ofjTuWW7cNdQ8gJCckMpP0k=
    =Yy3/
    -----END PGP SIGNATURE-----
     
    Stephen Hansen, Feb 5, 2011
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.