Include path of ASP stop working in Windows 2003

Discussion in 'ASP General' started by Charts, Jun 9, 2004.

  1. Charts

    Charts Guest

    I recently upgraded development web server to Windows 2003. I have ASP file contains following line for include file
    <!--#include File="../Include/adovbs.inc"--

    This ASP file worked fine before. When I ran this file under Windows 2003, I got following error message
    The include file “Include/adovbs.inc†cannot contain ‘…’ to indicate the parent directory.

    I changed to following lin
    <!--#include File="my virtual directory/Include/adovbs.inc"--

    Then, IE tells me the file could not be found

    If I copy the include file to the current directory and just use
    <!--#include File="adovbs.inc"-->
    That works

    Is there way I can change IIS setting to make my include path work†It really break my existing applications. Thanks
    Charts, Jun 9, 2004
    #1
    1. Advertising

  2. Charts

    Alan Howard Guest

    Try enabling parent paths - right click the site representing your app in
    IIS, select properties, select the Home Directory/Virtual Dir tab, click the
    Configuration button, select the App Options tab and select the Enable
    Parent Paths box. These instructions are for 2000 so adjust as necessary for
    2003 - pretty similar though.

    Alan

    "Charts" <> wrote in message
    news:...
    > I recently upgraded development web server to Windows 2003. I have ASP

    file contains following line for include file.
    > <!--#include File="../Include/adovbs.inc"-->
    >
    > This ASP file worked fine before. When I ran this file under Windows

    2003, I got following error message.
    > The include file "Include/adovbs.inc" cannot contain '.' to indicate the

    parent directory.
    >
    > I changed to following line
    > <!--#include File="my virtual directory/Include/adovbs.inc"-->
    >
    > Then, IE tells me the file could not be found.
    >
    > If I copy the include file to the current directory and just use
    > <!--#include File="adovbs.inc"-->
    > That works.
    >
    > Is there way I can change IIS setting to make my include path work" It

    really break my existing applications. Thanks.
    >
    Alan Howard, Jun 9, 2004
    #2
    1. Advertising

  3. Charts

    Charts Guest

    That works!! Thanks so much!

    "Alan Howard" wrote:

    > Try enabling parent paths - right click the site representing your app in
    > IIS, select properties, select the Home Directory/Virtual Dir tab, click the
    > Configuration button, select the App Options tab and select the Enable
    > Parent Paths box. These instructions are for 2000 so adjust as necessary for
    > 2003 - pretty similar though.
    >
    > Alan
    >
    > "Charts" <> wrote in message
    > news:...
    > > I recently upgraded development web server to Windows 2003. I have ASP

    > file contains following line for include file.
    > > <!--#include File="../Include/adovbs.inc"-->
    > >
    > > This ASP file worked fine before. When I ran this file under Windows

    > 2003, I got following error message.
    > > The include file "Include/adovbs.inc" cannot contain '.' to indicate the

    > parent directory.
    > >
    > > I changed to following line
    > > <!--#include File="my virtual directory/Include/adovbs.inc"-->
    > >
    > > Then, IE tells me the file could not be found.
    > >
    > > If I copy the include file to the current directory and just use
    > > <!--#include File="adovbs.inc"-->
    > > That works.
    > >
    > > Is there way I can change IIS setting to make my include path work" It

    > really break my existing applications. Thanks.
    > >

    >
    >
    >
    Charts, Jun 10, 2004
    #3
  4. Charts

    Charts Guest

    That works!! Thanks so much!!

    "Alan Howard" wrote:

    > Try enabling parent paths - right click the site representing your app in
    > IIS, select properties, select the Home Directory/Virtual Dir tab, click the
    > Configuration button, select the App Options tab and select the Enable
    > Parent Paths box. These instructions are for 2000 so adjust as necessary for
    > 2003 - pretty similar though.
    >
    > Alan
    >
    > "Charts" <> wrote in message
    > news:...
    > > I recently upgraded development web server to Windows 2003. I have ASP

    > file contains following line for include file.
    > > <!--#include File="../Include/adovbs.inc"-->
    > >
    > > This ASP file worked fine before. When I ran this file under Windows

    > 2003, I got following error message.
    > > The include file "Include/adovbs.inc" cannot contain '.' to indicate the

    > parent directory.
    > >
    > > I changed to following line
    > > <!--#include File="my virtual directory/Include/adovbs.inc"-->
    > >
    > > Then, IE tells me the file could not be found.
    > >
    > > If I copy the include file to the current directory and just use
    > > <!--#include File="adovbs.inc"-->
    > > That works.
    > >
    > > Is there way I can change IIS setting to make my include path work" It

    > really break my existing applications. Thanks.
    > >

    >
    >
    >
    Charts, Jun 10, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jason Shohet

    validators stop working on 2003 server

    Jason Shohet, Apr 8, 2004, in forum: ASP .Net
    Replies:
    2
    Views:
    306
    Jason Shohet
    Apr 9, 2004
  2. Andreas Bogenberger
    Replies:
    3
    Views:
    861
    Andreas Bogenberger
    Feb 22, 2008
  3. \A_Michigan_User\

    Various path/path/files.asp all #include this 1 file

    \A_Michigan_User\, Jul 10, 2005, in forum: ASP General
    Replies:
    1
    Views:
    221
    Jeff Cochran
    Jul 10, 2005
  4. Eric
    Replies:
    10
    Views:
    438
  5. Eric
    Replies:
    0
    Views:
    240
Loading...

Share This Page