Error Consuming Web Service from WIndows application when WebService is using Custom Service Accoun


D

DNB

NOTE: I have posted this message in
microsoft.public.dotnet.framework.aspnet also
I have a web service in .net 1.5 that I am consuming using windows
application.
I am running this windows application on Windows XP Pro.

Now if we use SQL server Authentication in WebService to connect to database
I am able to Invoke this web service from Windows Application(running on XP)

But as soon as I switch to Custom Service Account ( Create an Application
Pool with a Custom Identity) . I get following error while Invoking this
web service from Windows Application (running on XP)

"Server was unable to process request. --> Unable to generate a temporary
class (result=1).
error CS2001: Source file 'C:\WINDOWS\TEMP\noqnumwr.0.cs' could not be found
error CS2008: No inputs specified"


I tried following
go to c: > windows > temp
right clik and click on properties > Security >
here Click on Add and find out the NETWORK service user, add and then allow
full control.
Still it failed.



Thanks
DNB
 
Ad

Advertisements

J

John Saunders [MVP]

DNB said:
NOTE: I have posted this message in
microsoft.public.dotnet.framework.aspnet also
I have a web service in .net 1.5 that I am consuming using windows
application.
I am running this windows application on Windows XP Pro.

Now if we use SQL server Authentication in WebService to connect to
database
I am able to Invoke this web service from Windows Application(running on
XP)

But as soon as I switch to Custom Service Account ( Create an Application
Pool with a Custom Identity) . I get following error while Invoking this
web service from Windows Application (running on XP)

"Server was unable to process request. --> Unable to generate a temporary
class (result=1).
error CS2001: Source file 'C:\WINDOWS\TEMP\noqnumwr.0.cs' could not be
found
error CS2008: No inputs specified"


I tried following
go to c: > windows > temp
right clik and click on properties > Security >
here Click on Add and find out the NETWORK service user, add and then
allow
full control.
Still it failed.

Do you have auditing turned on for that system? If you did, then you could
look in the Security event log to see what failures happened, then see what
account they happened for, then enable that account to have that access.

Use Start->Run->gpedit.msc to turn on auditing. Navigate to Computer
Configuration->Windows Settings->Security Settings->Local Policies->Audit
policies. Here's how I have it set up on my machine:

Policy,Security Setting
Audit account logon events,Success, Failure
Audit account management,Success, Failure
Audit directory service access,Success, Failure
Audit logon events,Success, Failure
Audit object access,Failure
Audit policy change,Success
Audit privilege use,Success, Failure
Audit process tracking,Success, Failure
Audit system events,Success
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top