Rails OSX Tiger RMagick Bus Error Abort trap

Discussion in 'Ruby' started by Victor Rosillo, Sep 27, 2006.

  1. Hi;

    I am using a PowerBook G4 with:
    OSX Tiger version 10.4.7; Rubygems 0.9; Rails 1.1.6; RMagic 1.13.0

    I have Ruby and friends installed at /usr/local/...
    just as described in:
    http://hivelogic.com/articles/2005/12/01/ruby_rails_lighttpd_mysql_tiger

    then installed RMagick as descibed in:
    http://hivelogic.com/articles/2006/06/10/rmagick_os_x

    Then installed file_column and the full Rails environment worked fine
    for about four weeks. I could do script/console under iterm and get
    into the
    development environment.

    Then, I had to update Quicksilver, Rubygems and Rails; after
    that, I can't access script/console.

    If I do script/console under my Rails app dir in iterm, I get this:

    PBG4:~/Rails/app vr_mex$ script/console
    Loading development environment.
    /usr/local/lib/ruby/gems/1.8/gems/rmagick-1.13.0/lib/RMagick.bundle:
    [BUG] Bus Error
    ruby 1.8.4 (2005-12-24) [powerpc-darwin8.7.0]

    Abort trap

    So then I deleted all RMagick using: uninstall-RMagick.rb and went to
    install RMagick again via the same method:
    http://hivelogic.com/articles/2006/06/10/rmagick_os_x

    I got nowhere same error when I do script/console under my Rails app
    dir; so then I thought it had to do with file_column, so I went
    and tried it with acts_as_attachment via doing th sample Rails app in:
    http://weblog.techno-weenie.net/articles/acts_as_attachment

    For acts_as_attachment example to work, I had to install
    acts_as_attachment-1.1.6 that I got from here:
    http://svn.techno-weenie.net/projects/plugins/tags/acts_as_attachment...

    Well I got acts_as_attachment to work fine, but when I went into iterm
    and tried script/console, I got the same error as before; so clearly
    it is not a
    problem with acts_as_attachment or file_column

    Then from iterm I did this:
    PBG4:~/Rails/app vr_mex$ ruby -rrubygems -e "require 'RMagick'; puts
    Magick::Long_version;"
    This is RMagick 1.13.0 ($Date: 2006/06/26 23:32:37 $) Copyright (C)
    2006 by Timothy P. Hunter
    Built with ImageMagick 6.2.8 09/22/06 Q16 http://www.imagemagick.org
    Built for ruby 1.8.4 (2005-12-24) [powerpc-darwin8.7.0]
    Web page: http://rmagick.rubyforge.org
    Email:

    If i do this :
    PBG4:~/Rails/app vr_mex$ which ruby
    /usr/local/bin/ruby

    So I reinstalled Ruby and friends again at /usr/local/...
    just as described in:
    http://hivelogic.com/articles/2005/12/01/ruby_rails_lighttpd_mysql_tiger

    then reinstalled RMagick again as descibed in:
    http://hivelogic.com/articles/2006/06/10/rmagick_os_x

    And still getting the same error, can't get script/console to work.

    I need to have script/console access when using RMagic under Rails.

    Please Help
     
    Victor Rosillo, Sep 27, 2006
    #1
    1. Advertisements

  2. Uninstall RMagick and install it again from source - not from the gem -
    using the instructions at http://rmagick.rubyforge.org/install-osx.html.
    The installation includes running 175+ tests. Pay close attention to the
    output from these tests. Do you get any errors? If so, report them to
    . If not, then RMagick is installed and running
    properly and you need to look elsewhere for the problem. My guess
    (lacking any other information) would be that you have two versions of
    ImageMagick installed. To determine that you'll just have to search your
    filesystem. If that turns out to be the case, remove both *completely*
    and install ImageMagick and RMagick again *from source* using the
    procedure outlined in the RMagick installation FAQ.

    If you do have to re-install ImageMagick, think about using the
    --with-quantum-depth=8 option when you configure ImageMagick. For
    general images intended for the web and for printing on inkjet printers
    8 bits is enough and you'll cut your memory requirements in half and
    your CPU requirements almost in half.
     
    Timothy Hunter, Sep 28, 2006
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.